انجمن برنامه نویسی اندروید استودیو الکامکو - حل مشکل اندروید استودیو

قوانین و مقررات انجمن برنامه نویسان اندروید :

  • قبل از هرگونه پرسش و پاسخ برنامه نویسی اندروید و پشنهاد باید حتما در سایت عضو شده باشید.
  • هرگونه بی احترامی به اعضای انجمن برنامه نویسان اندروید ممنوع می باشد.
  • فقط کسانی می توانند در این انجمن شرکت کنند که در محیط اندروید استودیو و با زبان جاوا یا کاتلین، کدنویسی می کنند.
  • کلیه آموزش ها و مقالات پیرامون زبان قدرتمند جاوا یا کاتلین و در محیط اندروید استودیو مطرح می شوند.
  • این انجمن مخصوص افرادی می باشد که در دوره ها ی سایت ثبت نام کرده باشند.
  • به کلیه سوالات و اشکالات شما عزیزان توسط سایر اعضا انجمن برنامه نویسان اندروید الکامکو و یا مهندس محمد آزاد ، پاسخ داده می شود. | درباره ما
  • از همکاری تمامی شما عزیزان صمیمانه سپاسگذارم.

نرم افزارهای مورد نیاز برای آموزش برنامه نویسی اندروید :

  • اندروید استودیو
  • شبیه ساز Nox
  • شبیه ساز MEmu
  • نرم افزار DB Browser for SQLite برای کار با دیتابیس
  • نرم افزار JetBrains PhpStorm
  • نرم افزار XAMPP

انجمن تخصصی برنامه نویسی اندروید: معرفی و آموزش نصب نرم افزارهای مورد نیاز

  • شبیه ساز Nox ، نرم افزاری مفید برای افرادی می باشد که طرفدار اندروید هستند.
  • شبیه ساز Nox به شما این امکان را می دهد تا برنامه ها و بازی های اندروید خود را در ویندوز اجرا کنید.
  • شبیه ساز Nox یک شبیه ساز قدرتمند برای اپ های اندروید برای برنامه نویسان می باشد.
  • توسط این برنامه می توانید اپلیکیشن های اندروید را بدون داشتن گوشی یا تبلت اندروید، دقیقا به همان صورت در ویندوز خود تست و استفاده کنید.
  • با شبیه ساز Nox می توانید اپ های ساخته شده خودتان را تست کنید.
  • با شبیه ساز Nox می توانید از برنامه ای که روی دسکتاپ در حال نمایش است درست مثل زمانی که روی تلفن همراه خود با آن کار می کردید بهره مند شوید.
  • برای دانلود این نرم افزار کافیست یک جستجوی ساده در اینترنت بزنید.
  • سایت های فارسی زیادی از جمله soft98.ir به صورت رایگان این نرم افزار را به همراه کرک در اختیار شما قرار می دهند.

توجه :

دانشجویانی که در انجمن اندروید استودیو الکامکو فعالیت زیاد داشته باشند برای سایر دوره ها کد تخفیف دریافت خواهند کرد.

توجه :

در ورژن های جدید اندروید استودیو لینک http مورد تایید نیست. جاهایی که مثل لوکال هاست نمیتونید از لینک های https استفاده کنید، در مانیفست در انتهای تگ اپلیکیشن ابتدایی (application) خط کد زیر رو اضافه کنید.

android:usesCleartextTraffic=”true”

<application
        android:allowBackup="true"
        android:icon="@mipmap/ic_launcher"
        android:label="@string/app_name"
        android:roundIcon="@mipmap/ic_launcher_round"
        android:supportsRtl="true"
        android:theme="@style/AppTheme"
        android:usesCleartextTraffic="true">
        <activity android:name=".MainActivity">
            <intent-filter>
                <action android:name="android.intent.action.MAIN" />

                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>
        </activity>
    </application>

مهم (نصب اندروید استودیو و راه اندازی ایمولیتور) :

از آنجایی که آموزش نصب اندروید استودیو و کار با ایمولیتور، هم در مقالات موجود در سایت هست و هم در دوره به صورت کامل و مفصل توضیح داده شده است، به سوالات مربوط به نصب نرم افزار و نصب ایمولیتور که فقط ناشی از بی دقتی دانشجو میباشد، پاسخ داده نمیشود.

توجه : این انجمن تخصصی اندروید برای حل مشکلات اندروید استودیو و زبان برنامه نویسی جاوا و کاتلین است و فقط افرادی می توانند پرسش و پاسخ اندرویدی خود را مطرح کنند که دوره های آموزش برنامه نویسی اندروید الکامکو را خریده باشند.

دوره های آموزش برنامه نویسی الکامکو

مقالات آموزشی رایگان الکامکو برای شما

ویو پیجر2 اندروید چیست و چه فرقی با ویوپیجر دارد؟ ViewPager 2 vs ViewPager

بهترین رابط کاربری گوشی چیست؟ رابط کاربری تلفن همراه چیست؟ مقایسه انواع رابط کاریری موبایل - آموزش برنامه نویسی اندروید الکامکو

رابط کاربری گوشی چیست؟ انواع طراحی رابط کاربری موبایل؟ | UI

آموزش ساخت فرگمنت اندروید استودیو - fragment برنامه نویسی اندروید - الکامکو

فرگمنت چیست و در برنامه نویسی اندروید چه کاربردی دارد؟ | Android Fragment

.

آموزش برنامه نویسی اندروید را از کجا شروع کنیم؟ چه زبانی برای برنامه نویسی اندروید بهتر است؟ نرم افزارهای مورد نیاز برای آموزش برنامه نویسی اندروید کدام ها هستند؟ نصب نرم افزارهای مورد نیاز چگونه است؟ و… این‌ها سوالاتی هستند که بسیاری از افراد مبتدی که قصد یادگیری زبان برنامه نویسی را دارند همواره در هر انجمن اندرویدی به دنبال پاسخ آن‌ها هستند.

اما به راستی کجا می‌توانیم به دنبال راه حل‌های مناسب برای پرسش‌های خود بگردیم؟ بخاطر همین انجمن تخصصی اندروید به منظور حل مشکلات اندروید استودیو برای شما عزیزان ایجاد شده است.

هدف از ایجاد انجمن برنامه نویسی اندروید استودیو الکامکو، افزایش سطح دانش برنامه نویسی اندرویدبرای افرادی که می خواهند در این راه قدمی بردارند و وارد بازار کار اندروید شوند است. در ضمن فعالیت در این انجمن بصورت کاملا رایگان بوده و هیچ گونه هزینه ای را برای شما برنامه نویسان گرامی در پی نخواهد داشت.

از گروه پرسش و پاسخ اندروید استودیو الکامکو سوال دارید؟

خیلی وقت ها با سوالاتی برای ارورهای اندروید استودیو، رفع خطاهای اندروید استودیو و خلاصه مشکلات اندروید استودیو مواجه هستید که دوست دارید هر چه سریع تر آن ها را با دیگران به اشتراک بگذارید و جواب سوال هایتان را بگیرید.

پس پرسش و پاسخ برنامه نویسی اندروید خود را می توانید زیر همین پست با ما در میان بگذارید تا در سریع ترین زمان ممکن پاسخگوی شما عزیزان برنامه نویس باشیم. این صفحه از انجمن های برنامه نویسی اندروید ما مخصوص افرادی که دوره جامع را خریده باشند است و پشتیبانی الکامکو در این گروه برنامه نویسی اندروید استودیو پاسخگو این افراد است و در صورتیکه دوره ای نخریدید می توانید در انجمن های اندروید استودیو سول خود را بپرسید.      

567 دیدگاه
بازخورد درون خطی
مشاهده همه نظرات
محمدمهدی ب
2 سال گذشته

سلام
در قسمت دهم که از کتابخانه ها استفاده میشه متاسفانه به مشکل خوردم
کتابخانه ی design رو که نصب می کنم ارور می ده و یه چیزایی راجع به android x پیشنهاد میده
چیکار باید بکنم؟

محمدمهدی ب
2 سال گذشته

الان من در جلسه نهم به مشکل خوردم و وقتی که خوام برای ردیوباتن ها کد جاوا بنویسم کدش رو قبول نمی کنه و می نویسه سورس اندروید ۲۹ موجود نیست
در صورتی که موجوده و چند بار هم مجدد دانلودش کردم
کدی که براش می نویسم رو انجام نمیده
چیکتر باید بکنم؟

ata ahmadi
2 سال گذشته

سلام
استاد گرامی من در جلسه دهم هستم
بنده کتابخانه design را نصب کرده ام وبا موفقیت نصب شد implementation ‘com.android.support:design:28.0.0’
ولی وقتی میخوام در برنامه از آن استفاده کنم به جای android.support.design.widget.AppBarLayout از این دستور استفاده میکند
com.google.android.material.appbar.AppBarLayout
میخواستم علت را بدونم
تمام مراحل را با همین دستور اندروید انجام دادم ولی در آخر اجرا اسکرول نمیشه
با تشکر

محمد آزاد
پاسخ دادن به  ata ahmadi
2 سال گذشته

سلام . اگه کتابخانه سینک شده ایراد از جای دیگه هست . با دقت ویدیوی آموزشی را از اول ببین و همچنین فایل های ضمیمه رو با کدهای خودت مقایسه کن ببین ایراد از کجاست . ورژن sdk و کتابخانه رو در گردل با فایل های ضمیمه که ارسال شده مقایسه کن . همچنین زمانی که کرش میکنه eroor log رو ببین ایرات رو نوشته
implementation ‘com.android.support:design:28.0.0’
این کتابخنه رو اضاف کنی تگ زیر رو بدون هیچ مشکلی میتونی به لی اوت اضاف کنی
android.support.design.widget.AppBarLayout
امکانش هم هست که در حین نصب کتابخانه دیزاین یه لحظه فیلتر شکن قطع شده و متوجه نشدی

محمدمهدی ب
2 سال گذشته

سلام
همه چیز رو مو به مو طی کردن ولی فقط یک ارور میده Buidl Gradle Failed
نمی دونم مشکل از کجاست؟
وی پی ان پر سرعت هم وصله
همه چیز رو هم دانلود کردم
راه حلی برای این مشکل دارید؟

محمدمهدی ب
2 سال گذشته

سلام آقای ازاد یک سوال داشتم
من جلسه ی پنجم هستم و اندروید استودیو رو نصب کردم
اما دو مشکل دارم
1- هر کدی که میزنم هیچی نمیاره و تکمیلش نمی کنه. شما گفتید اول کلمه رو بنویسید و تو لیست گزینه ها رو میاره اما برای من هیچی نمیاره. هر کدی هم که می زنم می نویسه اینجا امکان استفاده از اون رو ندارید. روی تب مین اکتیویتی جاوا هم یه نقطه ی قرمز گذاشته نمی دونم دلیلش اروره یا چیز دیگه
2-
بخش Preview برای کد نویسی layout نمایش داده نمیشه و روی لودین مونده
ممنون

حمید
2 سال گذشته

سلام در قسمت ساخت پروژه ثبت نام و لاگین تا جلسه 39 ارور فایروال میده و به سرور متصل نمیشه لطفا راهنمایی کنید ممنون

محمد آزاد
پاسخ دادن به  حمید
2 سال گذشته

سلام . به علت استفاده از فیلتر شکن ، فایر وال سیستم شما جلوی اتصال به سرور رو میگیره . کد زیر رو به ابتدای تگ application در مانیفست اضاف کنید.

android:allowBackup=”true”

محمد زرآبادی
2 سال گذشته

تشکر از شما
ممنونم

محمد
2 سال گذشته

آقای آزاد شما استاد هستید و ما هم دانشجو شما این راه رو طی کردید و ما اول راه هستیم شاید این نکته ها به نظر شما ساده و پیش پا افتاده بیاد ولی برای من که اول راه هستم و تا الان با مفاهیم برنامه نویسی و اندروید آشنا نبودم کمی سخت و پیچیده به نظر می رسد و یک امر بدیهی است،ممنون ورژن ۲۹ رو برداشتم مشکلم حل شد،باز هم اگر با این سوالات پیش پا افتاده باعث رنجش شما شدم عذر خواهی میکنم.

محمد آزاد
پاسخ دادن به  محمد
2 سال گذشته

سلام دوست عزیز . منظورم این نبود که سوالاتتون باعث رنجش ما شده . ما هم یه روز مثل شما اول راه بودیم . منظورم این بود که زیاد واسه خودت پیچیدش نکن . یه مقدار استرست رو کم کن . یه مدت که کار کنی متوجه میشی که خیلی ساده تر از اونی هست که فکرشو بکنی . شما هر سوالی براتون پیش میاد بپرسید و ما وظیفمون هست که پاسخ بدیم بهتون بدون هیچ ناراحتی و رنجشی .

محمد
2 سال گذشته

و همچنین در سیستمم ورژن
appcmpat-v7:28.0.0 را ندارم
فقط ورژن 1.1.0rc01 موجوده

محمد آزاد
پاسخ دادن به  محمد
2 سال گذشته

از منوی tools ، زیر منوی Sdk Manager رو انتخاب کن و در تب SDK Tools و SDK Platform تیک Show package Detail رو بزن . تیک گزینه هایی که Api Level اونها 29 و یا Q هست رو غیر فعال کن . و ورژن 28 رو فعال کن .

محمد
2 سال گذشته

سلام
برنامه ای که پکیج نیم را تغییر دادیم تا کتابخانه دیزاین به آن اضافه کنیم در سیستم من به این صورت کامپایل شده
“BuildToolsversion “29.0.0
CompilesSdkversion 29
در صورت تغییرات به 28 و سینک نو ارور می دهد
لطفا راهنمائی کنید

محمد آزاد
پاسخ دادن به  محمد
2 سال گذشته

سلام . اندروید استودیو رو آپدیت کردی . به خاطر همین داره با ورژن 29 پروژه هات رو میسازه . شما 2 راه داری . یا فایل های گردل مربوط به ماژول اپ رو دقیقا ورژن هاشون رو با ورژن های فایل ارسالی که خودم فرستادم یکی کنی یا اینکه اگه از ورژن 29 استفاده میکنی ، کتابخونه هایی هم که اضاف میکنی با ورژن sdk یکی باشه که این موارد در سایت https://developer.android.com کاملا توضیح داده شده . اگر از راه اول استفاده کردی و به مشکل برخورد کردی صد در صد یه سری از کامپوننت ها رو نصب نکردی که نمیشناسه . از منوی tools ، زیر منوی Sdk Manager رو انتخاب کن و در تب SDK Tools و SDK Platform تیک Show package Detail رو بزن . تیک گزینه هایی که Api Level اونها 29 و یا Q هست رو غیر فعال کن . و ورژن 28 رو فعال کن . خیلی این موارد ساده و پیش پا افتاده رو واسه خودت پیچیده کردی . اگر هم از ورژن 29 استفاده میکنی کتابخونه هایی که اضاف میکنی باید ورژن 29 اونها رو ساپورت کنه و ورژن هاشون با هم مچ باشه . به همین سادگی

فهرست